Sobre este Documento

Este documento apresenta as perguntas tipicamente formuladas por potenciais usuários de soluções de colaboração via web utilizando o software SiteScape.

Estão apresentadas respostas, comentários e, sempre que possível, exemplos baseados em casos reais.

Autores: Álvaro Antônio Bueno de Camargo e Rivaldo Tamiazzo

Identificação: 01d0037-00

Emissão: 7.12.01

Página Inicial | Página Anterior | Página Seguinte


Sobre o SiteScape

O SiteScape é uma solução de colaboração via web que permite, a pequenos ou grandes grupos de usuários, localizados em qualquer lugar onde haja acesso Internet ou Intranet, compartilharem informações, arquivos e documentos, e desenvolverem discussões colaborativas.

Entre os múltiplos usos do SiteScape estão:

  • Apoio ao gerenciamento de projetos e obras, facilitando e monitorando o fluxo de informações entre pessoas de vários departamentos e empresas. Por exemplo, no Brasil, já é utilizado em obras de hidrelétricas, termelétricas, indústrias, etc.
  • Apoio ao gerenciamento de atividades de grupos distribuídos geograficamente. Por exemplo, no Brasil, é utilizado na coordenação e na manutenção de repositório central de documentos relacionados a atividades de cerca de 200 pesquisadores trabalhando na Amazônia;
  • Apoio a atividades de associações profissionais e internacionais, especialmente aquelas que geram normas em processo colaborativo. Um usuário típico é a International Standards Organization (ISO);
  • Apoio à troca de conhecimentos entre grupos de profissionais que se encontram em diferentes departamentos ou diferentes empresas coligadas. Usuários típicos são a Shell International Exploration and Production (SIEP) e a Siemens AG;
  • Manutenção de ambiente neutro e seguro para a troca de informações entre empresas que estão negociando fusões e associações, cooperando em consórcios, etc. Um caso típico foi o uso do SiteScape, pela 3Com, nas atividades de fusão com a US Robotics;
  • Na criação de fórum de troca e consolidação de conhecimento entre grupos de profissionais. Usuários típicos são universidades e associações técnicas.


Sobre a SiteScape, Inc.

A SiteScape, Inc. foi fundada em agosto de 1995, e evoluiu rapidamente de um value-added-reseller de soluções Internet para uma empresa fornecedora de soluções web, colaboração business-to-business e serviços ASP.

É sediada nos Estados Unidos e tem escritórios em Maynard, MA, Alexandria, VA e Wilmington, NC e Holanda.

No início das suas atividades, a SiteScape Inc. desenvolveu forte parceria com a AltaVista, na época era uma divisão da Digital Equipment Corporation, para comercializar as soluções de segurança, busca textual e colaboração via web.

Entre os parceiros tecnológicos da SiteScape Inc. estão AltaVista, Compaq, Citrix, Oracle, PlaceWare, Plumtree, RealityWave, Sun, Viador e Zoom On.


Para Mais Informações

Informações gerais sobre o SiteScape estão disponíveis em www.sitescape.com.

Informações sobre o serviço ASP baseado no SiteScape estão disponíveis em www.webworkzone.com.

Informações técnicas para usuários do SiteScape estão disponíveis em www.help.sitescape.com.

Informações sumárias em Português estão disponíveis em www.epcm.com.br.

Cotações detalhadas e demais informações:

Multidoc – Informática e Documentação Eletrônica
Rua Sacramento 126 – Conj. 74
13.010-911 Campinas, SP

Tel (19) 3233-6123
Fax (19) 3235-3588


Infra-Estrutura

Pergunta

Qual a infra-estrutura de hardware, software e telecomunicações necessária para operar uma aplicação SiteScape?

Resposta

O SiteScape requer um servidor com um dos seguintes sistemas operacionais:

Windows NT 4.0, 2000, XP
Linux
Unix Tru64
Sun Solaris

O servidor deve ter no mínimo 128 Mbytes de memória RAM (recomenda-se 256 MBytes ou mais, dependendo do número de usuários e sistema operacional).

Casos Reais

Numa aplicação no Brasil, que gerencia informações e documentos de duas obras de grande porte, com cerca de 120 usuários, é utilizado um servidor Pentium III 1 Ghz com 512 Mbytes de memória com sistema operacional Windows 2000 Server.

Numa outra aplicação, que gerencia mais de 120.000 documentos de cerca de 25 obras de grande porte, é utilizado um servidor Pentium III 850 Mbyte com 256 Mb de memória RAM e sistema operacional Windows NT 4.0.


Funcionalidades

Pergunta

Quais são os pontos fortes e os pontos fracos do SiteScape?

Resposta

Os pontos fortes do SiteScape são:

É uma completa aplicação de colaboração via web, com recursos de repositório central, notificação via E-Mail, workflow, pesquisa textual, chat, instant messaging, votação, etc.

Opera 100% via web (Intranet, Extranet, Internet). O usuário só precisa ter acesso web e um navegador (browser) convencional.

Pode ser licenciado para uso em servidor próprio ou assinado como serviço ASP hospedado em servidor externo.

É de rápida implantação (poucas semanas).

Utiliza conceitos simples, de fácil assimilação.

Baixo preço de licenciamento por usuário.

Baixo Custo de Propriedade ( TCO - Total Cost of Ownership)

Baseado em tecnologias conceituadas (AltaVista)

Workflow é de facílima configuração, dispensando programação.

Os pontos fracos do SiteScape são:

Utiliza uma solução de base de dados proprietária e não uma solução convencional de mercado. Apesar desse banco de dados proprietário atender muito bem às necessidades do SiteScape, este é um ponto fraco quando se deseja integrar o SiteScape com outras bases de dados. A partir da versão 7.0, que já está em testes beta, será possível optar entre a base de dados proprietária do SiteScape ou bases relacionais de mercado, como Oracle ou SQL Server.

A documentação de ajuda on-line é detalhada porém carece de recursos visuais. A linguagem utilizada nos itens relativos à customização do produto é bastante técnica e requer conhecimento da linguagem TCL.

Para customização no nível de código fonte, para acrescentar novas funcionalidades ao produto, requer conhecimento da linguagem TCL. (Os demais níveis de customização são feitos com simples configuração, sem necessidade de programação.

Casos Reais

Até o momento nenhum usuário SiteScape no Brasil teve necessidade de customizações envolvendo o código fonte.

Os benefícios tem sido sentidos a curto prazo, mas o total aproveitamento de soluções de colaboração via web só ocorre depois de um certo tempo. O conceito de colaboração efetiva entre equipes de trabalho (via web ou convencional) é uma cultura nova, ainda embrionária na maioria das empresas.


Integração Empresa, Parceiro, Fornecedor e Cliente

Pergunta

Como é feita a passagem de informações e documentos entre uma empresa e seus fornecedores, clientes e parceiros ?

Resposta

A principal aplicação do SiteScape é exatamente a de gerenciar o intercâmbio de informações e documentos entre diversas entidades, como por exemplo, uma empresa e seus clientes, fornecedores e parceiros comerciais. O SiteScape tem plenos recursos para restringir o que cada usuário pode ver ou fazer no sistema.

Se algum envolvido não fizer parte do workgroup SiteScape, ele poderá receber ou encaminhar informações via E-Mail.

Se alguma empresa utilizar outros sistemas de colaboração, a troca de informações entre o SiteScape e esse sistema pode ser automatizada via programas a serem desenvolvidos segundo as necessidades específicas.


Tipos de Arquivos

Pergunta

Que tipos de arquivos podem ser armazenados no SiteScape?

Resposta

Arquivos gerados por quaisquer aplicativos podem ser armazenados no SiteScape. A visualização ou possibilidade de edição dependem do navegador utilizado. Se o navegador não puder visualizar ou editar o arquivo, será necessário fazer download para o disco local e abrir o arquivo com um aplicativo instalado no computador do usuário.

O SiteScape efetua buscas textuais em vários formatos:

Processadores de Texto: MS Word, HTML e 57 outros formatos.

Planilhas Eletrônicas: MS Excel e 23 outros formatos

Bancos de Dados: MS Access e 18 outros formatos

Gráficos (só nas versões Windows): BMP, CGM, DXF, GIF, JPEG, TIFF e 49 outros

Apresentação: Corel Presentations, Freelance, PowerPoint e 3 outros.

Formatos Comprimidos: GZIP, MIME, UUEncode, ZIP e 5 outros formatos.

Outros Formatos: Executáveis, MS Project (texto) e vCard.


Integração com Bases de Dados

Pergunta

O SiteScape pode se integrar com Bases de Dados?

Resposta

A partir de campos URL definidos em bases de dados (Commence, Access, SQL Server, Oracle, etc.) é possível acessar qualquer informação existente no SiteScape. Todos os registros do SiteScape têm endereço URL específico. Se esse endereço for armazenado num campo URL da base de dados, bastará clicar nesse campo para acessar o documento.

É claro que isto requer:

  • Que o usuário tenha navegador web;
  • Que o usuário tenha acesso ao servidor onde está instalado o SiteScape (Intranet ou Internet, dependendo do caso);
  • Que o usuário tenha UserID e senha de acesso ao SiteScape (exceto se a aplicação SiteScape estiver configurada para admitir usuários anônimos).


Passagem de Documentos para Operação

Pergunta

No final de uma obra ou projeto, como é feita a passagem de informações e documentos do SiteScape para os sistemas de operação?

Resposta

No final de uma obra ou projeto toda a documentação estará armazenada no servidor SiteScape estruturada em "pastas" segundo os assuntos do projeto e também acessível através dos recursos de pesquisa textual.

Essa estrutura pode ser transferida, por exemplo para discos óticos, e constituirá o acervo histórico da obra ou projeto, podendo ser consultado com a utilização do SiteScape.

Mas, é claro, entre os documentos importantes para a operação do empreendimento esse acervo conterá também documentos que só tiveram valor durante a obra ou projeto.

Uma melhor solução poderá ser obtida criando-se um novo repositório, estruturado segundo as necessidades operacionais, para onde serão duplicados apenas os documentos de interesse.

Se, por outro lado, a empresa desejar transferir esses documentos para outros sistemas de gerenciamento da operação, cadastros técnicos, etc., cópias dos documentos poderão ser transferidas via exportação.


Desempenho do Sistema

Pergunta

Qual o tempo máximo para se visualizar um documento armazenado no SiteScape?

Resposta

O desempenho depende de muitos fatores, como o tipo e a carga do servidor, o tamanho do documento, o formato do documento, o visualizador utilizado, a velocidade da linha de comunicação, etc.

Em casos reais a grande maioria dos documentos tipo office é visualizada no navegador (browser) entre 1 e 5 segundos. Documentos tipo CAD de grande porte podem demorar até alguns minutos para serem visualizados.

Uma alternativa usual, no caso de documentos de grande porte, é fazer-se o download clicando com o botão direito do mouse sobre o link do documento. Dependendo do tipo de arquivo que se quer visualizar, é freqüentemente mais rápido fazer o download e depois visualizar o documento com o uso de um aplicativo local. A visualização de documentos através do navegador sempre é mais lenta do que em aplicativos desktop.


Confiabilidade

Pergunta

O sistema congela, tem paradas graves?

Resposta

Por trabalhar como um serviço executado em background no servidor, é muito raro que o SiteScape trave. Um ponto importante para evitar problemas é o uso de links de alta velocidade na comunicação com o servidor.

Nos casos em que o SiteScape está na Internet e que o acesso se faz através de estação de uma rede corporativa, é muito comum que a configuração de ferramentas de proteção, como por exemplo um firewall, limitem o tamanho de arquivos que podem ser transferidos através da Internet. A configuração incorreta de firewalls é a maior causa de falhas no uso do SiteScape.

Também é comum o congelamento da operação de visualização ou download quando se utiliza proteção antivírus na estação e o arquivo armazenado no SiteScape está contaminado por vírus.

Outra causa relativamente comum de problemas é a má administração do espaço em disco em servidores do SiteScape. Quando um disco está próximo do limite de capacidade, a operação do SiteScape deve ser transferida para um servidor com espaço adequado ou o servidor atual deve sofrer um upgrade.

O esgotamento do espaço em disco num servidor SiteScape sem que haja uma sistemática de backup é garantia de problema.


Segurança de Acesso

Pergunta

São usados ou considera-se usar serviços de entidades certificadoras, como por exemplo a CertSign?

Resposta

A certificação diz respeito à conferência da identificação dos participantes de uma transação. (Quando alguém diz que é ele mesmo, está falando a verdade ?)

O SiteScape é um espaço virtual de troca de arquivos, documentos e informações. Quem certifica o usuário é o próprio administrador do sistema ao fornecer o UserID e a senha inicial do usuário. Posteriormente o usuário pode trocar sua senha mas não pode trocar seu UserID. O administrador do sistema não tem acesso à senha do usuário uma vez que ele a modifique.

O SiteScape pode utilizar um serviço externo de manutenção da lista de usuários através do protocolo LDAP (Light Weigth Directory Access Protocol). Sempre que se altera o bando de dados do serviço de diretório é possível sincronizar com a ACL (Acess Control List) do SiteScape.

Se a entidade certificadora fornecer um serviço LDAP é possível utilizar o serviço da mesma para garantir uma maior segurança no acesso.

Casos Reais

Até o momento os clientes de SiteScape no Brasil consideraram suficiente o sistema de segurança próprio do SiteScape, e não estão utilizando serviços de entidades certificadoras.


Facilidade de Uso

Pergunta

O sistema é considerado de fácil uso tanto pelo pessoal de nível superior quanto pelo pessoal de nível médio?

Resposta

Sim. Em geral todos concordam que o sistema é muito fácil de se usar. O difícil é implementar a disciplina de se colocar todas as informações e documentos relevantes no sistema.

Casos Reais

Há casos reais em que a maioria dos usuários é constituída por pessoal de nível médio, e casos reais onde a maioria dos usuários é constituída por gerentes de projeto e engenheiros. Em geral o pessoal de nível mais alto é mais resistente a seguir a disciplina imposta pelo sistema, em especial a do workflow.


Integração com Scanner

Pergunta

O sistema está integrado com scanner de tal modo que o acionamento desse dispositivo se faça através do próprio SiteScape?

Resposta

O SiteScape não tem recurso nativo de integração com scanner.

Na realidade, não há SiteScape instalado no computador do usuário pois toda a operação é feita através de browser.

Aplicativos de interface com scanner podem ser desenvolvidos utilizando a biblioteca de funções do LeadTools (produto também distribuído pela Multidoc).

Em geral, as empresas evitam o uso descentralizado de scanners face à demora dos processos de digitalização.

A situação mais comum é e existência de setores especializados em digitalização, que utilizam equipamentos mais sofisticados e operadores especializados que digitalizam documentos, processam o resultado (retoques, OCR, etc.) e armazenam o resultado no SiteScape.


Integração com Plotter

Pergunta

O SiteScape permite a impressão via Plotter?

Resposta

Sim, a impressão via plotter é possível mas isso é função do navegador ou do visualizador que estiverem sendo usados. Em geral, os visualizadores profissionais têm interface para impressão via plotter.

Lembrar que o SiteScape não é instalado no computador do usuário e que todas as operações são executadas via browser.


Número de Usuários

Pergunta

O SiteScape é vendido em blocos de 200 usuários. O que são 200 usuários ? São 200 usuários registrados ? Ou são 200 usuários conectados ?

Resposta

Cada usuário registrados no SiteScape tem um UserID e uma senha.

A licença SiteScape é composta de 1 administrador, 1 usuário anônimo e usuários comuns que podem ser registrados, cada qual com seu UserID e senha de acesso, até o limite total de usuários adquiridos.

Um mesmo usuário pode se conectar ao sistema mais de uma vez, ao mesmo tempo, em mais de uma estação. Assim, as áreas do SiteScape que estiverm franqueadas para visita por usuário anônimo poderão ser visitadas por milhares de pessoas simultaneamente.


Suporte Técnico

Perguntas

Quem oferece o suporte técnico? A SiteScape Inc. (USA), o distribuidor no Brasil, ou ambos?

Resposta

Ao licenciar o SiteScape o usuário pode optar por um contrato de suporte anual, que dá direito a atualizações e suporte via E-Mail, diretamente do fabricante, durante um ano.

Adicionalmente, pode firmar contratos de suporte técnico junto à Multidoc, para atendimento via telefone, E-mail e/ou visitas periódicas.

Caso Real

Em caso real recente, para um grupo de 120 usuários, nos primeiros meses, o suporte técnico via telefone atendia cerca de 5 perguntas por dia. Após o terceiro mês o ritmo de perguntas caiu para cerca de 1 a 2 perguntas por mês.


Volume de Dados

Pergunta

Há restrições quanto ao volume de dados que o SiteScape pode manipular?

Resposta

Não. O SiteScape está preparado para tratar grandes volumes de dados. As restrições existirão apenas em função da capacidade do servidor.


Multimídia

Pergunta

O SiteScape pode manipular arquivos multimídia (áudio, vídeo, ...) ?

Resposta

O SiteScape pode armazenar qualquer tipo de arquivo. A visualização depende da capacidade no navegador e dos módulos add-on nele instalados. Caso não haja add-on para uso no navegador de um determinado tipo arquivo, será necessário fazer o download e utilizar um aplicativo instalado no computador do usuário para visualizar e/ou alterar o arquivo.

Casos Reais

É frequente a utilização de visualizadores para desenhos Autocad. Por exemplo, o visualizador VoloView da AutoDesk. Outras opções são o CadViewerPro,da ZoomOn e o WizStream da RealityWave.


TCL

Pergunta

O que é o TCL ? Por que o SiteScape foi desenvolvido com TCL ?

Resposta

O TCL - Tool Command Language é uma linguagem de script desenvolvida pelo Dr. John Ousterhout da Universidade da Califórnia, Berkeley.

O SiteScape utiliza o TCL e as principais razões são:

O TCL é uma linguagem multiplataforma. Há versões para Unix, Sun Solaris e Windows. O SiteScape é uma ferramenta multiplataforma.

O TCL é uma linguagem interpretada, de fácil aprendizagem e extremamente veloz para aplicações web. Por exemplo, se escrito em Java, o SiteScape não teria a mesma velocidade.

O TCL é uma linguagem aberta. Sua utilização é livre de pagamento de royalties e está sempre sendo aperfeiçoada por usuários do mundo todo, da mesma forma como ocorre com o sistema operacional Linux.


WorkFlow

Pergunta

O workflow do SiteScape é simples de usar?

Resposta

Sim. É muito fácil montar e utilizar uma estrutura de workflow com o SiteScape.

No entanto, na maioria das empresas, trabalhar com processos monitorados por computador ainda é uma novidade. Processos formais de workflow podem mudar a forma como as pessoas trabalham e, se bem montados, expõem de forma muito clara as eventuais deficiências das pessoas. Isso pode criar resistências ao uso do recurso de workflow e do próprio SiteScape.

Casos Reais

Em caso real recente houve substancial aumento de produtividade ao se introduzir procedimentos de workflow no controle de pendências.

Reuniões semanais que envolviam muitas pessoas, e cuja agenda consumia muitas horas, passaram a ser feitas muito mais rapidamente e passaram a tratar apenas dos assuntos que realmente exigiam reunião formal. Os demais assuntos passaram a ser identificados, discutidos e resolvidos continuamente, via sistema de colaboração (SiteScape).


Edições Internacionais

Pergunta

Existe uma edição do SiteScape em Português ? Quais são as edições internacionais do SiteScape ?

Resposta

O SiteScape está na versão 6.0, para a qual existem edições em Inglês, Francês, Espanhol, Holandês e Alemão.

Uma edição em português foi feita no Brasil para a versão 5 e está em uso numa aplicação relacionada a área governamental.

Para os usuários atuais, a versão em inglês é satisfatória (e, em alguns casos, especificada). Mas a Multidoc está preparada para traduzir o SiteScape se houver suficiente demanda.


Usuários

Pergunta

Quem usa o SiteScape no Brasil e no mundo ?

Resposta

Alguns usuários do SiteScape no Brasil são: Alstom Power, Serpro, Construções e Comércio Camargo Corrêa S.A. e Genamaz (Rede Inter-institucional para Conservação e Uso dos Recursos Genéticos Amazônicos).

Alguns usuários internacionais são: Boeing, Compaq, EDS, Fiat, Ford, Intel, Lockheed Martin, ISO - International Standards Organization, SAE – Society of Automotive Engineers, Shell, Siemens, 3Com e US Coast Guard.


Licenciamento

Pergunta

Como é licenciado o SiteScape? Há desconto para compra por volume ?

Resposta

O SiteScape é comercializado em blocos de 200 usuários. O cliente pode optar por adquirir pacotes de 200, 400, 600, 800 e 1000 usuários ou por licença ilimitada para mais de 1000 usuários.

O preço unitário tem descontos progressivos em função da quantidade.

No momento não são comercializados lotes com menos de 200 licenças.

Página Inicial | Página Anterior | Página Seguinte


Glossário

ACL

ASP

CAD

LDAP

OCR

TCL

TCO

UserID

Página Inicial | Página Anterior | Página Seguinte


ACL

Access Control List – É uma lista de controle de acesso a recursos. Por exemplo, quando um usuário executa o processo de login no Windows sua identificação e senha são confrontadas com uma ACL para verificar se o usuário pode ser autenticado e usar o sistema. O SiteScape possui sua própria ACL mas também pode usar a ACL do Windows NT ou 2000. A autenticação do usuário também pode ser feita através de serviços centrais mantidos em servidores LDAP.


ASP

Application Service Provider. Refere-se a soluções de processamento de informações hospedadas em servidores Internet e oferecidas via web.


CAD

Computer Aided Design. Tipo de software voltado para a execução de projetos assistidos por computador.


LDAP

Light Weigth Directory Access Protocol - É um protocolo para manutenção de um acervo central de identificação de usuários e senhas. Com o uso de um servidor LDAP é possível fazer com que o usuário se identifique uma única vez e tenha acesso a diversos recursos de diversos aplicativos e sistemas.


OCR

Optical Character Recognition (reconhecimento ótico de caracteres) - Processo de conversão de imagens de imagens capturadas por scanner para arquivos legíveis por processadores de texto, etc.


TCL

Tool Command Language - Linguagem de script utilizada pelo SiteScape. Foi desenvolvida pelo Dr. John Ousterhout da Universidade da Califórnia, Berkeley e há inúmeras soluções comercias e websites comerciais desenvolvidos com TCL.

Mais informações sobre TCL podem ser obtidas em http://TCL.activestate.com/


TCO

Total Cost of Ownership - significa o custo total de uma solução, incluindo investimentos de implantação, sistemas periféricos necessários e custos de operação e manutenção.


UserID

Identificação do usuário. Para entrar no SiteScape é necessário fornecer seu UserID e sua senha pessoal. Também pode-se entrar no sistema como anônimo desde que o administrador tenha configurado o sistema com tal permissão.